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Summary
This document provides directions and prompts to get started using the Water Evaluation
and Planning (WEAP) system to simulate reservoir operations in the Lower Bear River, Utah.
Students will (i) add demand site(s), reservoir(s), transmission links, and return flows to
complete the Lower Bear River schematic, (ii) enter data for these model elements, (iii) define
scenarios to represent both current conditions and adding two new reservoirs, and (iv) simulate
and identify the effects each new reservoir will have on water deliveries to new urban users in
Cache County.
Introduction
The Bear River covers an area of about 7,600 square miles in Utah, Idaho and Wyoming
(Figure 1). There are numerous reservoirs in the Bear River basin including upstream storage
reservoirs like Woodruff, Bear Lake, and Oneida Narrows. On the Little Bear River which is a
tributary to the Bear River, there is also Hyrum Reservoir. Cutler Reservoir is located on the
Bear River but has very little storage capacity. Additionally, there are several proposed on- and
off-stream storage reservoirs including Barrens, Above Cutler, Honeyville, and a site above
Honeyville that could supply water to either Cache or Box Elder Counties or the Wasatch Front.
The most senior (highest priority) water rights holder in the basin is the Bear River Canal
Company which is located in Box Elder county downstream of Cutler Reservoir. The lower Bear
River study area starts at the Idaho-Utah border and has its outlet at the Great Salt Lake. The
major tributaries to the Lower Bear River include the Cub, Little Bear, and Malad Rivers. There
are major demand urban and agricultural demand sites both in Cache Valley and Box Elder
County.The Utah Division of Water Resources (UDWR) developed the GenRes (FORTRAN)
model to simulate the monthly historical (1966-2006) water allocation within the basin. Here, we
will construct a simplified version of the UDWR model in WEAP.
Original UDWR Model
The UDWR GenRes model (Figure 2) includes 6 existing reservoirs (Idaho, Oneida,
Millcreek, Hyrum, Willard Bay, and Davis), 3 potential reservoirs (Barrens, Washaskie,
Mainstem), and 11 service areas (including the Bird Refuge). A service area is a group of canals
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or diversions that serve agricultural, urban, or environmental users and is alternatively refered to
as a “demand site” in WEAP. The UDWR model allocates water among service areas based on
priorities (Table 1). Demand sites that have the high priorities (numbers closest to 1) are
allocated their full deliverty targets first before sites with lower priorities are allocated any water.

Figure 1. Bear River Basin with Lower Bear River study area highlighted in orange
(adapted from UDWR, 2000).
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Figure 2. UDWR Bear River simulation model schematic

3

The WEAP Model
WEAP was developed by the Stockholm Environemntal Institute in 1988 and is a
software package to help plan and manage water supply. WEAP operates on the principle of
mass-balance, and allocates water based on the priorities specified for the system components
such as the demand sites, reservoirs, environmental flows (SEI, 2007). WEAP has been used in
numerous water resources studies throughout the world, including the Aral Sea (Raskin et al.,
1992); Upper Chattahoochee River Basin, Georgia (Johnson, 1994); South Africa (Levite et al.,
2003); Sacramento River, California (Purkey et al., 2008); Austin, Texas; Portland, Oregon; and
Philadelphia, Pennsylvania (Huber-Lee et al., 2005). Here, you will use WEAP to represent
demand sites, reservoirs, transmission links (diversions), and return flows and enter their data.
WEAP partitions reservoir storage into zones (Figure 3). The Flood Zone is reserved to
capture flood flows, while the Conservation Zone defines water storage to meet the full delivery
requirements of urban, agricultural, hydropower, or other demand sites that draw from the
reservoir. Should reservoir storage drop into the Buffer Zone, water deliveries are cut back below
the full delivery amount. This cutback amount is specified by the buffer coefficient which
determines the fraction of water in the buffer zone to be released. Users can enter the reservoir
zone levels and buffer coefficient in WEAP to create model scenarios representing different
reservoir storage and release operations and simulate the associated results such as deliveries to
and shortages at demand sites (SEI, 2007).
This document will guide you through completing a WEAP model for the Lower Bear
River. You will specify three scenarios. One scenario will represent a base case of current
conditions (only existing reservoirs). A second scenario will add the proposed reservoir Above
Cutler to the base case. And a third scenario will add the proposed Barrens reservoir to the base
case. Finally, you will simulate each scenario to determine the effects on the demand sites.
Table 1. Bear River Basin Demand Site Priorities
Priority Service Area No.
Name
Included in WEAP Model
1
1
Bear River Canal (Company)
2
2
Bird Refuge
3
6
Cache Valley New
4
3
Cache Valley Irrigation
6
4
New Box Elder County
7
5
Box Elder County
Excluded from WEAP Model
5
NA
Wasatch Front
8
NA
South Cache
9
NA
South Cache
10
NA
Idaho
11
NA
Weber Basin

4

Use Type
Irrigation
Environmental
Municipal
Irrigation
Irrigation
Municipal
Municipal
Municipal
Irrigation
Irrigation
Municipal

Figure 2. Definition of the operation zone parameters required by WEAP (Adapted from
SEI, 2007).
Simplifying Assumptions
In building the WEAP model from the UDWR Fortran model, you should:
1. Use UDWR model flows on QX5
(release from Oneida) to
represent headflow on the lower
Bear River. This assumption
avoids the need to model
upstream Idaho reservoirs,
demand sites, diversions, and
head flows.
2. Similarly, use UDWR model
flows on QX54 to represent flow
on the Little Bear and Blacksmith
Fork rivers into Cutler. Again,
this assumption avoids the need
to model upstream components
on those rivers.
3. Ignore head flows, reservoir
operations, and demand sites in
the Weber Basin and along the
Watach Front.
4. Ignore the Barrens, Washakie,
and Mainstem (Honeville)
reservoirs since they are no
longer under serious
consideration.

Figure 4. Simplified schematic for Lower Bear
River

These assumptions will allow you to
simplify the model schematic (Figure 4).
5

Directed Activity
Below are the steps to follow to get started with building a model of the Lower Bear River in
WEAP. Instructions in Bold or Italic refer to WEAP program items (windows, menus, tabs,
input items, etc.). There are also numerous resources—User Guide, forums, etc.—available to
help you use WEAP which we will introduce you to in the next section.
WEAP Resources, Installation, and Sample River Basins
1.

Go to the WEAP home page (http://www.weap21.org/) and overview the resources
available for you. These resources include a demonstration, user guide, tutorials, and user
forums.

2.

Download and install WEAP (skip Step 2 if you are working on a computer where the
program is already installed).
a. On the left side of the WEAP home page under Using WEAP, click Download, join
the WEAP forum, login with your newly assigned password, and follow the directions
from there. Also, read the box “Download WEAP” (below) and start downloading.
Download WEAP
The free, evaluation version of WEAP (53 MB) is a fully working version of the software-only the Save Data feature is disabled. To enable, you will need a license number (see step 2b
below). This download can also be used to upgrade any existing versions of WEAP.
WEAP requires Windows 2000, XP, Vista or 7, and at least 256 MB of RAM. To install
WEAP, right click on the setup program (WEAP_Install.exe) and choose Run as
Administrator. The WEAP program (weap.exe) will install under Program Files; WEAP data
files will be stored under My Documents.
In some cases, when WEAP is first run the following error message appears: 'Unable to merge
new configuration, use BDE Administrator to merge your new configuration'. This is not a
problem--click OK to continue. It may also suggest that you should restart your computer, but
this is not necessary.

b. The free version of WEAP you downloaded is an evaluation version and therefore has
limited use. Opening the program will prompt you to register the program. To register,
enter the User Name and Registration Code (provided by your professor). After
registering, enter your initials and click “End user information” in the window
provided.
3.

Open the program and explore the Weaping River Basin sample model.
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a. In the Schematic mode (click top icon at left), explore the system spatial
configuration. How many reservoirs, aquifers, and demand sites are in the sample
model?
b. In the Data mode (click second icon at left), explore the types of data entered.
The data is organized into a tree of Key Assumptions, Demand Sites, Hydrology,
Supply and Resources, Water Quality and Other Assumptions. How are demands
disaggregated and entered for the South City and Agricultural North demand
sites? Is this disaggregation the same for other sites? Note this disaggregation is
different from demand data in the Weber River Basin case study.
c. In the Results mode, explore the numerous available results for one or multiple
model runs (scenarios); four scenarios are defined in the model (Demand
Measures, Integrated Measures, Reference, and Supply Measures). In the Chart
view, use the drop-down menu to select results to view. What menu option would
you select to view shortages at a demand site (i.e., the difference between the
actual delivery and the delivery target)?
d. Click the Scenario icon to view, define, and compare results from the various
scenarios created.
The Lower Bear River Basin
Area Setup
4.

Unzip the zip file named LowerBearRiver-WEAP-Start.zip available on the class website
which contains a partially-complete WEAP watershed for the Lower Bear River basin.
Unzip the folder into C:\Documents and Settings\...\My Documents\WEAP Areas\. Keep
the area name LowerBearRiver-CEE5460. If WEAP is already open, close and then
reopen it.

5.

From the Area menu, select Open and select the area LowerBearRiver-CEE5460 from
the list. The model should load, and you should see the Lower Bear River Basin
schematic. Note that this project includes many of the schematic elements for the Lower
Bear River Basin but a few are missing! Compare the WEAP schematic to Figure 4.
a. What reservoirs, demand sites, and other elements need to be added in WEAP?

Model Schematic
6.

The Schematic mode has three tool boxes arranged in a column just to the right of the
Schematic, Data, Results, etc. icons at the far left. The top box provides tools to add
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elements to the model. The middle box shows GIS files which can be layered onto the
schematic. And the lower box shows a wide-angle zoom of the schematic.
7.

Now, add the elements you identified as missing in Step 5a.
a. To add a Demand Site (Service Area in Figure 2 or Box in Figure 4), go to the top
box and check Demand Site.
i. Click the Demand Site label in the box, drag it, and drop it at the desired
location. Note that you need place Demand Sites only approximately on
the WEAP schematic since no shape file layers exist to help in placing.
ii. After dropping, a General Info window will open. Enter a Name and
Optional Label.
iii. Use Table 1 to decide the Demand Priority. Recall this priority (similar to
water rights) determines the order in which scarce water is allocated and
delivered to demand sites. Higher priority (lower numbered) sites receive
their full demands before lower priority (higher numbered) sites receive
any water.
iv. Keep all other options to default values and click OK.
b. Repeat Step 7a for other Demand Sites that need to be added to the schematic.
c. Add Transmission Links by dragging the transmission link tool, clicking on the
starting point, and dragging to an ending point at a desired Demand Site. Keep all
other options to default values. You can also add a Return Flow from a Demand
Site back to the river using a similar procedure.
d. Place the proposed reservoirs in their target locations. Again, click and drag the
reservoir icon to the appropriate location on the schematic. In the General Info
window that opens, enter a Name. Leave the Demand Priority at the default
setting of 99. Since the reservoir is new, it will have the lowest priority to fill
should there be surplus water in a year.
e. All the other river and groundwater components should be present on the
schematic. But check!

8.

After adding all the missing elements, save your work!
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Data Entry
9.

Now enter data for the model elements present on the schematic by selecting the Data
icon. When entering data, make sure to press Enter after each data entry. Also,
information on inflows, demand sites, and reservoirs that you can use for inputs is
organized in the file LowerBearRiverModelData.xlsx also available on the class website.
You will need to enter data for headflows, reach gains, demand sites, transmission links,
return flows, and reservoirs.

10.

First, on the Data For dropdown list, make sure to select Current Accounts.

11.

Headflows. Headflows are the most upstream flow inputs to river elements in the WEAP
model and are indicated by the corresponding most-upstream arrows in Figure 4 on each
river. Each arrow is also labeled with a name. To assign headflow data:
a. In the data tree, select Supply and Resources=>River. A data window will open
with the Headflow tab highlighted. You will be prompted to enter average
monthly inflow at the head of the river. Below, you will see a table for the three
rivers (Bear River, Little Bear River, and Malad). Headflow data has already been
entered for the Bear River. The original headflow data is located on the “QX5LowerBRInflow” worksheet of the Excel file. The worksheet was saved in CSV
(comma separated values) format in the WEAP area, then WEAP reads in the
CSV file. Now repeat this process for the Little Bear and Malad rivers.
b. In the Excel file, select the worksheet that has headflow data for the Little Bear
River. On the File menu, select Save As... and in the window that opens set Save
as type: to CSV (comma delimited) *.csv and give the file an appropriate name
and save it in your WEAP area folder. Note, saving an Excel file as a CSV will
only save the active worksheet.
c. Back in WEAP, click inside the cell in the 1966 column for the river. A dropdown list icon will appear. Click it and select ReadFromFile Wizard. A file
window will open. Navigate to and select the CSV file you created in step 10(a)i.
A new window will show you a graph of the time-series you just selected. Click
Finish to return to the Data window.
d. Repeat steps b and c to define the headflow for the Malad River. Note, you will
not enter water quality or cost data for rivers.

12.

Reach inflows. Reach inflows are local or tributary inflows (sometimes called reach
gains) that flow into a river at downstream locations. These reach inflows are also
indicated by arrows in Figure 4 and labeled by source (QX15-South Cache Reach Gain;
QX22-Malad Reach Gain). Note that the reach inflow data time-series you have been
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provided includes values that are both positive (gains) and negative (losses). WEAP can
only accept positive values. To accommodate this: In Excel, split each reach inflow time
series into two time series – and two CSV files. One time series to represent the nonnegative values (substitute zeros for original values that are negative; Series A). And a
second series that only shows the negative values but turns them positive; Series B. i.e.,
Original = Series A – Series B).
a. Reach gains (positive values). Return to the data tree and open the River=>Bear
River branches and select Reaches. The Surface Water Inflow tab will appear at
the right with a table for all the Bear River reaches. Enter reach inflows (positive
values) for the reaches that require it as you did in steps 11b and 11c above. Note,
only select reaches have reach inflows. And you need only enter Surface Water
Inflow data for reaches. To which reaches did you assign reach gains?
b. Reach losses (negative values). We will represent reach losses as required
diversions out of the river. We will add a flow requirement to the diversion to
require flow through the diversion to represent the reach loss.
i. On the schematic, add a Diversion just below the node you assigned the
reach gain to in step (a). Make sure the Priority is set to 1 (so the reach
loss is satisfied first) and leave all settings at their default values.
ii. Add a Flow Requirement to the diversion you created in step b(i). Rightclick on the flow requirement, and select Edit Data=>Minimum Flow
Requirement. In the data window that opens, click the cell for 1967-2006,
open the drop-down list, and select ReadFromFile Wizard. Then read in
the file you created to represent the negative values.
13.

Demand Sites. Demand sites are locations where water is desired to be used and are
represented by boxes or ovals in Figure 4. In the schematic, right click one of the
Demand Sites. Select Edit Data=>Method. A data window will open.
a. Select the Advanced button at the far right. In the Method table, click the
Demand Site name, select Specify monthly demand, and press enter.
b. Select the Water Use button. On the Annual Activity Level tab, change Unit to AF
(acre foot). Click in the cell 1967-2006, select Monthly timeseries wizard, and
enter montly demands in the new window using the demand site data provided in
the Excel file.
c. On the Consumption tab, enter the appropriate Consumption rate for the site
based on the return flow fraction data provided in the Excel file.
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d. Ignore the Loss and Reuse, Demand Management, Water Quality, and Cost
buttons. But verify that the Priority setting is correct. Remember that priorities
for demand sites should all be less than the priorities previously entered for reach
losses Step 12b.
e. Repeat steps a to d for each Demand Site.
14.

Transmission Links. In the schematic, right click on a Transmission Link and select Edit
Data=>Maximum Flow Volume. Leave nearly all settings at their default values (i.e.,
unlimited capacity, no losses, and no costs). On the Supply Preference tab, verify that
transmissions from the Bear River have highest priority (1) and that transmissions from
other sources (the Malad River, groundwater, etc.) have lower priority (2).

15.

Return Flows. Right click on a Return Flow, and select Edit Data=>Return Flow
Routing. Again, leave all settings at their default values (i.e., 100% return flow routing,
zero loss from system, zero groundwater loss, zero gain from groundwater, and no costs).
What does a setting of 100% return flow routing mean?

16.

Reservoir Data. On the schematic, right click on a reservoir you created in Step 7, and
select Edit Data=>Storage Capacity. A data window will open. Enter the Physical,
Operation, and Priority data for the reservoir by clicking the various buttons.
a. Physical Data: On the Storage Capacity and Initial Storage tabs, enter data using
the appropriate units. On the Volume Elevation Curve tab, use the two column
table provided to enter data for the Volume-Elevation Curve. On the Net
Evaporation tab, chose Monthly Time-Series Wizard under the year 1950. Then
enter the monthly values provided. Leave Loss to Groundwater at the default
setting of zero.
b. Operation Data defines the reservoir zones (pools) and releases from them.
Enter storage volumes that correspond to the Top of Conservation, Top of Buffer,
and Top of Inactive pools. Enter the Buffer Coefficient as a number between 0 and
1 to indicate the fraction of water in the buffer pool available for release each
month (should the storage level drop into the buffer pool). Remember, the new
proposed reservoirs will be used primarily to supply water and the buffer pool
represents the storage level at which deliveries to demand sites are cut back (by
the buffer coefficient).
c. Note, you will not enter hydropower, water quality, or cost data for reservoirs.
d. Make the reservoir inactive (for the base case). Click the Physical Button again.
In the Storage Capacity tab, set the reservoir capacity to zero.
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17.

Congratulations! You have now (hopefully) entered all the model data.

Model Results
18.

With the system schematic represented and all pertinent data entered, you can now run
the model and generate results for the base case that represents current conditions.

19.

Click the Results icon. When asked to recalculate results, select Yes.

20.

There are numerous results to view and explore in WEAP. To view results for an
element, right-click the element and select View Results and the result type. For
example:
a. Which demand site(s) have unmet demand (i.e., experience shortage(s))?
b. What is the reliability of deliveries to the Bear River Canal Company and New
Urban Users in Cache County?
c. What is the annual firm yield / annual firm delivery to New Urban Users in Cache
County (a water year starts in October and ends in September of the following
year)?
d. A variety of tools are available at the right-hand-side of plots to reformat and
export results, including exporting to Excel. What is the delivery-reliability curve
for New Urban Users in Cache County?

Scenario Explorer
21.

Scenarios allow you to test the effects of new infrastructure, operations, demand
forecasts, climate projections, or other changes to model inputs. In this exercise, you will
create and test two scenarios representing the addition of two new reservoirs.

22.

The first scenario will add the Above Cutler reservoir.
a. First, create the scenario. Click the Data icon. On the top row of the data page,
click the Manage Scenarios button. In the Manage Scenarios window select
Current Accounts(1966) and click the Add button at the top left corner of the
window. Finally, Name the new scenario something meaningful like With Above
Cutler. Click OK and close the windows to return to the Data page.
Now change one or more inputs to reflect the new scenario. What input data did
you change and where? [Hint: Return to Step 16].
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b. Run the new scenario (see Step 19). What are the answers to questions 20a–d
above?
23.

Create a second scenario that represents the inclusion of the 2nd reservoir instead of
Above Cutler. (Hint, either repeat Step 22 or use the dashboard in the Scenario Explorer).
Again, what are the answers to questions 20a–d above? To compare results among
scenarios:
a. Go to the Results mode. Select a result type from the dropdown menu located on
the top middle of the screen. Choose a convenient unit for the volume.
b. Choose a location, make sure that the All months option is selected, and unselect
the Monthly Average box.
c. In the dropdown menu to the right of the label Monthly Average, choose No
Comparison. From the far right drop down menu, choose All Scenarios. Make
sure All Years is selected at the bottom of the window.
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